Uploaded image for project: 'Grouper'
  1. Grouper
  2. GRP-1161

Ensure Grouper builds have the right Java ver installed

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • None
    • 2.2.2, 2.3.0
    • None
    • None

    Description

      Modify the build system to make sure the build is using Java 6, and nothing else. This prevents a ton of problems later on with database drivers, etc.

      Put out a huge warning and disclaimer out into the console that:

      MAKE SURE YOU ARE RUNNING JAVA 6.
      IF YOU ARE NOT, YOU ARE VYING FOR A WORLD OF PAIN.
      MAKE SURE ALL JARS SUCH AS DB DRIVERS ARE COMPATIBLE WITH JAVA 6.

      etc.

      Attachments

        Activity

          People

            chris.hyzer@at.internet2.edu Chris Hyzer (upenn.edu)
            misagh.moayyed@at.internet2.edu Misagh Moayyed
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Smart Checklist