Uploaded image for project: 'Grouper'
  1. Grouper
  2. GRP-402

versions in grouper ws should be more flexible

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6.0
    • Fix Version/s: 1.6.0
    • Component/s: WS
    • Labels:
      None

      Description

      right now there are enums, which means if the client is upgraded, and not the server, it will be a failure. Here are examples of what we want

      //cli -> ser -> ok?
      //1.5.2 -> 1.5.2 -> T
      //1.5.2 -> 1.5.1 -> T
      //1.5.1 -> 1.5.2 -> T
      //1.5.2 -> 1.4.0 -> F (released before 1.5.2)
      //1.5.2 -> 1.4.5 -> F (released after 1.5.2)
      //1.4.0 -> 1.5.2 -> T (released before 1.5.2)
      //1.4.5 -> 1.5.2 -> T (released after 1.5.2)
      //1.6.0 -> 1.5.2 -> F
      //1.5.2 -> 1.6.0 -> T
      //2.0.0 -> 1.5.2 -> F
      //1.5.2 -> 2.0.0 -> T

        Smart Checklist

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                chris.hyzer@at.internet2.edu Chris Hyzer (upenn.edu)
                Reporter:
                chris.hyzer@at.internet2.edu Chris Hyzer (upenn.edu)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: