Uploaded image for project: 'Shibboleth Discovery Service - Java'
  1. Shibboleth Discovery Service - Java
  2. SDSJ-70

Seelcteing drop down with the mouse changes select button to search.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.1.2
    • Labels:
      None
    • Java Version:
      Sun 1.6
    • Servlet Container:
      Apache Tomcat 6.0

      Description

      [From Edina person]

      I wonder if it is
      working quite as you were expecting.

      suppose I choose [new interface] and [search over all sites]

      If I type EDINA in the search box it shows three entries (as expected) in
      the dynamic drop-down list:
      EDINA (trial only)
      EDINA - Development
      EDINA Services for schools

      as I move the mouse over the generated list, the [search] button becomes
      [select].

      If I select an entry from the dynamic list, instead of being directed to the
      selected IdP, the selected entry is copied to the search box and the button
      changes back to [Search]

      For example (continuing from above):
      If I select [EDINA (trial only)] the [select] button changes to [search]
      and click [search] I get the search results containing the three EDINA
      sites, plus [Birkenhead Sixth Form College (Shib2 - test only)]
      I assume its matching on ([edina] or [only])

      If I select [EDINA services for schools] and click [select] I get a list of
      70+ institutions as its matching on [for] etc.

      Similarly, try selecting [Cheadle and Marple Sixth Form College] - the list
      returned from the search is very long - because its also mapping on [and],
      [college] or [form] - all very common letter groups.

      I don't think this is the intended behaviour; I don't think that having
      selected an entry the button should have reverted to [search]

      Another minor comment. If I select [all sites], then would it be expected
      that the [all sites] link changes to [filtered sites] or some such?

      I've tried using my old IE6 and my new firefox 3.2 and the results are
      consistent

        Smart Checklist

          Attachments

            Activity

              People

              • Assignee:
                rdw Rod Widdowson (Inactive)
                Reporter:
                rdw Rod Widdowson (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: