Uploaded image for project: 'COmanage'
  1. COmanage
  2. CO-1823

Duplicating an existing flow is not working properly

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Minor
    • COmanage Registry 3.2.3 (Oyster Pearl MR3)
    • Registry
    • Registry: 3.2.3
      Browser: Mac OS X Version 78.0.3904.97 (Official Build) (64-bit)

    Description

      If I create and configure an enrollment flow, I cannot successfully duplicate the flow to make a new one. Duplicating the flow causes it to lose memory of the old flows configuration, and registry is refusing to update the configuration of the new flow.

      Screen shots of reproducing the problem are attached. Steps (corresponding to images) are:

      1. Create and configure an enrollment flow. Here I have set the default COU to PrincipalInvestigarors, hidden, not modifiable.
      2. Duplicate the active flow and go into COU to edit. Notice that the COU blank and both the modifiable and hidden boxes are checked, so registry has forgotten the configuration from the original workflow.
      3. I re-configure the COU to CEProject, hidden, not modifiable, and save.
      4. I re-edit the attribute and registry has forgotten the state.

      This works fine if I go back to the template and start from scratch, but I can't duplicate an existing flow.

      Attachments

        1. for_benn_1.png
          for_benn_1.png
          1.09 MB
        2. for_benn_2.png
          for_benn_2.png
          8.55 MB
        3. for_benn_3.png
          for_benn_3.png
          1.09 MB
        4. for_benn_4.png
          for_benn_4.png
          1.09 MB

        Issue Links

          Activity

            People

              benn.oshrin@at.internet2.edu Benn Oshrin
              duncan.brown@at.internet2.edu Duncan Brown
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: